*
Welcome, Guest. Please login or register.
December 17, 2018, 01:20:27 AM

Login with username, password and session length

Recent

Author Topic: Problems priming Blitzkrieg Vehicles  (Read 696 times)

Offline Wellington

  • assistant
  • Posts: 23
Problems priming Blitzkrieg Vehicles
« on: October 09, 2018, 10:32:31 PM »
Hi!

I encountered a problem, I never had bevor. I bought a Armoured Car and a Mathilda Tank form the Blitzkrieg Range.

https://www.perry-miniatures.com/product_info.php?cPath=23_74_78&products_id=2915&osCsid=40skhisu9r3au7f4fite9vvfm6

As usually I let soak them a few days in water with dish cleaner and scrub them bevor priming them with GW or Army Painter.

First I used the Desert Yellow Primer from Army painter. After a few days I picked it up to start painting, I detected that the primer was flaking of. After peeling of the primer, soaking in water again and trying to prime it with Black Primer from Army Painter, I got the same result.

Any advice how to clean the resin?

Cheers

Wellington
« Last Edit: October 09, 2018, 10:52:16 PM by Wellington »
A life without Samurai is possible, but not desirable!

Offline grant

  • Supporting Adventurer
  • scatterbrained genius
  • *
  • Posts: 3942
Re: Problems priming Blitzkrieg Vehicles
« Reply #1 on: October 09, 2018, 10:39:33 PM »
I’ve never had that problem with Blitzkrieg. I airbrush Vallejo Primers.
It’s a beautiful thing, the destruction of words - Orwell, 1984

Offline Ultravanillasmurf

  • scatterbrained genius
  • Posts: 3935
    • Ultravanillasmurf
Re: Problems priming Blitzkrieg Vehicles
« Reply #2 on: October 11, 2018, 12:55:36 PM »
I use scouring cream applied with an old toothbrush, not built any Blitzkrieg kits so do not know what the resin is like.

I vaguely remember Antenocitis suggesting using talcum powder.

Is it a surface issue or is it coming out of the resin (I have a resin container that bleeds through paint, varnish and superglue...).

Offline Wellington

  • assistant
  • Posts: 23
Re: Problems priming Blitzkrieg Vehicles
« Reply #3 on: October 11, 2018, 05:27:03 PM »
its a pure surface issue, to smooth for the primer. But it works on the turrets!

I love the models, they are great!

Some friends made some suggestions, I have to try!

Offline Captain Blood

  • Global Moderator
  • elder god
  • Posts: 15624
Re: Problems priming Blitzkrieg Vehicles
« Reply #4 on: October 11, 2018, 06:22:50 PM »
I had this on one or two of my Blitzkrieg AFVs to start with. I have now taken to washing all resin models in detergent water, and then, once dry, priming with handpainted Humbrol enamel. It sticks to the resin a LOT better than spray on primers.

Offline Volleyfire!

  • scientist
  • Posts: 358
  • At 100 yards................Volleyfire!!!
Re: Problems priming Blitzkrieg Vehicles
« Reply #5 on: October 13, 2018, 11:25:14 AM »
Warm water and a long soak in a decent washing up liquid works for me. I undercoat spray with Battlefront or Army Painter cans and don't normally have any issues, although the Battlefront one can sometimes flake but I find a second coat does the trick.

Offline ARKOUDAKI

  • mad scientist
  • Posts: 508
Re: Problems priming Blitzkrieg Vehicles
« Reply #6 on: October 20, 2018, 06:49:48 PM »
For resin kits I recommend Tamiya Fine Surface Primer. Works great and you don't lose any detail.

Offline Wellington

  • assistant
  • Posts: 23
Re: Problems priming Blitzkrieg Vehicles
« Reply #7 on: November 11, 2018, 07:46:05 PM »
Finally it worked! And I love the models! I have to buy some more.

I used a special type of primer called "Haftgrundierung" in German, special for very smoth surfaces and applied it with an brush. Then I used Armypinter Desert Yellow. And it worked!
« Last Edit: November 11, 2018, 07:49:58 PM by Wellington »